미디어 위키를 설치하려고 하는데 pcre 버전이 낮아서 설치할 수 없다는 메시지가 발생.

  • 설치된 버전 확인
# rpm -q --queryformat "%{name}.%{arch}\n" pcre
  • 기존 버전 삭제 (--nodeps 옵션으로)
# rpm -ev --nodeps pcre-devel.x86_64
# rpm -ev --nodeps pcre.x86_64
# rpm -ev --nodeps pcre-devel.i386
# rpm -ev --nodeps pcre.i386
  • yum repo 에 추가
vi /etc/yum.repos.d/utter-ramblings.repo

후 아래 내용 추가

[utter-ramblings]
name=Utter Ramblings
baseurl=http://www.jasonlitka.com/media/EL5/x86_64/
gpgkey=http://www.jasonlitka.com/media/RPM-GPG-KEY-jlitka
enabled=1
gpgcheck=1
  • yum 을 이용해 다시 설치
# yum --disablerepo=* --enablerepo=utter-ramblings install pcre pcre-devel
  • 웹서버 재시작 후 phpinfo 확인


+ Recent posts